PDA

Afficher la version complète : Htc Magic - Mobile Vikings - Problème caractère SMS



meneo
08/09/2009, 11h17
Voilà, j'ai depuis quelques temps un HTC Magic venu d'allemagne, je l'ai couplé au réseau Mobile Vikings, que du bonheur!
J'ai flashé le bazar avec une ROM XDA (je ne sais plus laquelle en fait) et le tout est rooté.
Tout fonctionne à merveille, rapide, réactive et stable.

Seul soucis: les SMS. Le destinataire ne reçoit pas le sms en entier, celui-ci fini généralement par "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@".

Je n'ai pas encore comprit si c'est lors d'envoi de SMS avec des caractères accentués (ç - é - à - â - î - ÿ - ...) ou si c'est lorsque le SMS est plus long (double ou triple SMS).

Je suis le seul à avoir ce problème? Celà vient donc bien de la ROM et pas de Mobile Vikings?

Quelqu'un a une idée pour résoudre le problème?

Merci bien!

oni269
08/09/2009, 18h34
Cela provient du client sms. Il passe en mode utf-8. Qui n'est pas toujours reconnu par les gsm, je sais que ce bug est présent sur tous les gsm Android HTC et même sur mon Sony Ericsson qui à deux ans.

Eniotna89
08/09/2009, 19h26
J'ai aussi ce problème, je crois que tous les androids l'ont.
Dès que tu dépasses un certains nombre de caractères, ça déconne...

Regarde ici si tu veux plus d'infos ;)
http://www.frandroid.com/4497/mise-a-jour-android-du-htc-hero/

meneo
08/09/2009, 23h23
Ah ben vi => http://code.google.com/p/android/issues/detail?id=2719

C'est dingue, on devrait en entendre plus parler pourtant!

oni269
08/09/2009, 23h40
Je vous déconseille de passer par les upgrades officielles HTC.

Au niveau du MAGIC je m'occupe (d'autre aussi) de faire des upgrades propres qui ne bousillerons pas le fastboot de votre gsm (on peux revenir en arrière sur le magic mais pas au SPL d'origine du téléphone)

Niveau Hero il existe des ROM qui ne remplacent pas le SPL.

Quand vous choisissez une ROM faites toujours attention qu'elle ne flash que le system et le boot.

Ne flashez le reste qu'en dernier recours.

Enfin c'est mon conseil mais j'aime être prudent ^^

Freed
09/09/2009, 14h52
Que lis-je?!

Je n'avais jamais entendu parler de ce GROS problème!
Moi qui m'apprêtais à enfin me faire plaisir avec un smartphone... :blink:

Le problème est donc bien réel et insoluble sans recourir à des méthodes pseudo pirates?

oni269
10/09/2009, 09h39
Ce qui est dommage c'est que ce problème existe depuis plusieurs années sur différents modèles et différentes marques de gsm.
En gros j'ai l'impression qu'ils en ont rien a battre en général lol.

Freed
12/09/2009, 12h18
Ce qui est dommage c'est que ce problème existe depuis plusieurs années sur différents modèles et différentes marques de gsm.
En gros j'ai l'impression qu'ils en ont rien a battre en général lol.

Salut Oni,

Peux-tu me dire quels gsm sont concernés à ta connaissance?
Je serais trop dégoûté d'en acheter un qui aurait justement ce problème...

Merci ;)

oni269
12/09/2009, 15h06
Le bug se situe pour moi au niveau du gsm qui reçoit.
Une amie a un Sony Ericsson récent et quand je lui envoyait un message de mon k610i avec des â elle recevait un truc bizarre. Après je ne sais pas du tout quel gsm a des soucis en réception ou émission. Mais le debug le plus simple c'est d'éviter ces accents lol